Disabling hibernate on a Linux PC

My sons and I just rebuilt my father-in-law’s Dell PC with Arch Linux. Windows had rotted to the point where system was too slow to use even though we’ve re-installed windows several times on this machine over the past years. When audio quit working under Windows, we decided it was time for something different.

After installing Linux, everything pretty much just worked (including audio). Also amazing what a SSD drive will do to speed up an older computer.

Hibernate did not work (who needs that anyway as sleep generally works better), so I wanted to disable the menu option so he did not accidentally get the system stuck. After a little research I learned there is a systemd config:

After setting:


The hibernate option just disappeared from the KDE menu options.

This is the way things should work!


I wonder if there is some detailed view of systemd power management features. It will be handy